CVE-2024-5181 – A command injection vulnerability exists in the mu

CVE ID : CVE-2024-5181

Published : June 26, 2024, 3:15 a.m. | 1 hour, 5 minutes ago

Description : A command injection vulnerability exists in the mudler/localai version 2.14.0. The vulnerability arises from the application’s handling of the backend parameter in the configuration file, which is used in the name of the initialized process. An attacker can exploit this vulnerability by manipulating the path of the vulnerable binary file specified in the backend parameter, allowing the execution of arbitrary code on the system. This issue is due to improper neutralization of special elements used in an OS command, leading to potential full control over the affected system.

Severity: 9.8 | CRITICAL

Visit the link for more details, such as CVSS details, affected products, timeline, and more…CVE ID : CVE-2024-5181

Published : June 26, 2024, 3:15 a.m. | 1 hour, 5 minutes ago

Description : A command injection vulnerability exists in the mudler/localai version 2.14.0. The vulnerability arises from the application’s handling of the backend parameter in the configuration file, which is used in the name of the initialized process. An attacker can exploit this vulnerability by manipulating the path of the vulnerable binary file specified in the backend parameter, allowing the execution of arbitrary code on the system. This issue is due to improper neutralization of special elements used in an OS command, leading to potential full control over the affected system.

Severity: 9.8 | CRITICAL

Visit the link for more details, such as CVSS details, affected products, timeline, and more…